I came across the IBM G8124 while providing some pre-sales architecture to some of my clients. As HomeLab'ers it's difficult to afford some modern datacenter switch that we can afford. Most all 10G switches are over $1000 unless you are looking on the used market and then most of the switches are old and power hungry. It's easy to locate these on EBay and the prices have been dropping as they get a little older. Because most of us are using SDN (software defined working) they work very well in low cost lab situations where 10G offers some really nice benefits. When paired with some Emulex OCE11102 dual port 10G NICs it's possible to get a full 10G network for less than $500.
The G8124 is considered a Top-of-Rack switch that maintains some incredibly low port to port latency, about .600 nanoseconds. It also supports Virtual Fabrics and L3 routing with OSPF. This switch offers some really nice features when fitted in a HomeLab where VMware vSAN, NSX, VRA and other goodies want to be learned. If this solution is of interest one thing to note is for connectivity to the rest of your network you will need to have either a 10G interface in your existing switch or you will need a 1G SFP interface. The 2 x 1G interfaces are strictly for out-of-band management. Many IBM systems feature 2 dedicated management interfaces that require a different network than any SVI assigned and each management interface are required to reside on different networks as well. It is possible to only use a single management interface or manage the switch through one of the SVIs. While I wouldn't recommend this in a production environment for a lab, have at it, knock yourself out.
The config is a little different than the Cisco language but not very difficult to get past if you are familiar with the concepts. Documentation and firmware are still available from IBM. Below are some links for this and model information.
Firmware and Docs
https://www.ibm.com/support/home/search-results/5422459/IBM_RackSwitch_G8124,_8124E_-_7309,_0446,_1455_7309?docOnly=true&sortby=-dcdate_sortrange&ct=rc
Model Info
https://lenovopress.com/tips0787
Example code (shortened to remove redundancy)
!
version "7.11.9"
switch-type "IBM Networking Operating System RackSwitch G8124-E"
iscli-new
!
system timezone 145
! America/US/Eastern
system daylight
!
ssh enable
!
snmp-server location "CloudRoom"
snmp-server read-community "HNET"
!
no system bootp
no system dhcp mgta
no system dhcp mgtb
no system default-ip
hostname "10gNET"
no hostname prompt
system idle 60
!
!
no access telnet enable
!
!
interface port 1
switchport mode trunk
switchport trunk allowed vlan 1,3,5,10,70-71,80-85,98-102,201-209,250,252,301-339
bpdu-guard
flowcontrol send on
flowcontrol receive on
exit
!
interface port 11
switchport access vlan 98
bpdu-guard
exit
!
interface port 12
switchport mode trunk
switchport trunk allowed vlan 1,3,5,10,70-71,80-85,98-102,201-209,250,252
exit
!
interface port 15
switchport access vlan 202
flowcontrol send on
flowcontrol receive on
exit
!
interface port 16
switchport access vlan 201
flowcontrol send on
flowcontrol receive on
exit
!
interface port MGTA
shutdown
exit
!
interface port MGTB
shutdown
exit
!
vlan 10
name "LAB1"
!
vlan 70
name "VLAN 70"
!
vlan 201
name "iSCSI-201"
!
vlan 202
name "iSCSI-202"
!
vlan 205
name "ESXi-vMotion"
!
vlan 206
name "ESXi-FT"
!
vlan 250
name "Home-NET"
!
vlan 252
name "GuestNET"
!
portchannel 13 lacp key 100
portchannel 14 lacp key 101
!
!
!
spanning-tree mst configuration
name "local"
exit
!
spanning-tree mode disable
!
no spanning-tree pvst-compatibility
spanning-tree stp 1 vlan 1
spanning-tree stp 1 vlan 3
!
!
logging host 1 address 192.168.98.48 DATA
!
interface port 13
lacp mode active
lacp key 101
no lacp suspend-individual
!
interface port 14
lacp mode active
lacp key 101
no lacp suspend-individual
!
interface port 23
lacp mode active
lacp key 100
no lacp suspend-individual
!
interface port 24
lacp mode active
lacp key 100
no lacp suspend-individual
!
interface ip 1
ip address 100.64.254.254 255.255.255.0
enable
exit
!
interface ip 3
vlan 3
exit
!
interface ip 70
ip address 192.168.70.254
vlan 70
enable
exit
!
!
ip bootp-relay server 1 address 192.168.98.21
ip bootp-relay server 2 address 192.168.98.22
ip bootp-relay information enable
ip bootp-relay enable
!
!
ip igmp snoop vlan 1
ip igmp enable
ip igmp snoop enable
!
ip igmp snoop igmpv3 enable
!
ip route 0.0.0.0 0.0.0.0 100.64.254.1
ip route 192.168.251.0 255.255.255.0 192.168.250.245
ip route 192.168.8.0 255.255.248.0 192.168.250.250
!
router ospf
enable
!
area 0 enable
!
interface ip 1
ip ospf enable
!
ntp enable
ntp primary-server 192.168.98.21 DATA
ntp secondary-server 192.168.98.22 DATA
!
end